CVE-2026-16051

Critical

Description

The wpmudev-updates WordPress plugin before 5.0.1 does not verify the integrity of the packages installed through its remote management interface, nor protect those requests against replay, allowing an attacker able to obtain or replay a valid signed management request to install and execute arbitrary code (remote code execution).

SeverityCritical
CVSS9.8
Exploit probability—
ProductWpmudev-updates
PublishedAug 12, 2026
First seenAug 12, 2026

How to fix

Update
  • wpmudev-updates5.0.1 or later

Affected products

ProductAffected versionsFixed in
wpmudev-updatesv < 5.0.15.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.