CVE-2026-16221
Description
Impact: fast-uri versions from 2.3.1 through 4.1.0 (including the 3.x line up to 3.1.3 and the 2.x line up to 2.4.2) do not treat a literal backslash character (U+005C) as an authority delimiter. Node's native WHATWG URL parser, used by fetch, undici, and Node's http and https clients, normalizes the backslash to a forward slash for special schemes such as http, https, ws, wss, ftp, and file. As a result, the two parsers extract different hosts from the same input string. Applications that use fast-uri to enforce host-based policy such as allowlists, denylists, loopback or SSRF filtering, redirect validation, or outbound proxy routing before passing the same URL into Node's URL or fetch consumers can be steered to an unintended destination, including cloud metadata endpoints, loopback, or internal hosts. Patches: upgrade to fast-uri 4.1.1, 3.1.4, or 2.4.3. Workarounds: none.
How to fix
- openjsf fast-uri2.4.3, 3.1.4, 4.1.1 or later
- fast-uri2.4.3, 3.1.4, 4.1.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| openjsf fast-uri | 2.3.1 ≤ v < 2.4.3, 3.0.0 ≤ v < 3.1.4, 4.0.0 ≤ v < 4.1.1 | 2.4.3, 3.1.4, 4.1.1 |
| fast-urinpm | 2.3.1 ≤ v < 2.4.3, 3.0.0 ≤ v < 3.1.4, 4.0.0 ≤ v < 4.1.1 | 2.4.3, 3.1.4, 4.1.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.