CVE-2026-18245

Critical

Description

Improper control of code generation in Amazon @aws-amplify/codegen-ui-react before 2.20.6 might allow a remote authenticated user to execute arbitrary code in end-user browsers, developer machines, CI/CD environments, and server-side rendering contexts via crafted Studio component or theme schema values due to insufficient coverage and effectiveness of the input validation introduced for CVE-2025-4318. To remediate this issue, users should upgrade to version 2.20.6

SeverityCritical
CVSS9.0
Exploit probability—
ProductAmazon Amplify Codegen Ui
PublishedJul 30, 2026
First seenJul 30, 2026

How to fix

Affected products

ProductAffected versionsFixed in
amazon amplify_codegen_uiv < 2.20.62.20.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-18245 · Amazon Amplify Codegen Ui · Dark Radar