CVE-2026-18394

High

Description

Incorrect authorization in the http_request tool in Strands Agents Tools before 0.8.2 might allow remote attackers to obtain credentials configured via HTTP_REQUEST_TOKEN_CONFIG by influencing the LLM to route requests through actor-controlled proxy infrastructure. To remediate this issue, users should upgrade to version 0.8.2.

SeverityHigh
CVSS7.4
Exploit probability—
ProductStrands Agents Tools
PublishedJul 31, 2026
First seenJul 31, 2026

How to fix

Affected products

ProductAffected versionsFixed in
AWS Strands Agents Toolsv < 0.8.20.8.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.