CVE-2026-18654
Description
Key exchange without entity authentication in the EMR SSH helper commands in Amazon AWS CLI before 1.45.28 and AWS CLI v2 before 2.35.3 might allow man-in-the-middle attackers to intercept SSHsessions and file transfers via network positioning between the client and the EMR cluster endpoint. To remediate this issue, users should upgrade to AWS CLI v1 1.45.28 or later, or AWS CLI v2 2.35.3 or later.
How to fix
- amazon aws_command_line_interface1.45.28, 2.35.3 or later
- awscli1.45.28 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| amazon aws_command_line_interface | v < 1.45.28, 2.0.0 ≤ v < 2.35.3 | 1.45.28, 2.35.3 |
| awscliPyPI | v < 1.45.28 | 1.45.28 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.