CVE-2026-1868
Description
GitLab has remediated a vulnerability in the Duo Workflow Service component of GitLab AI Gateway affecting all versions of the AI Gateway from 18.1.6, 18.2.6, 18.3.1 to 18.6.1, 18.7.0, and 18.8.0 in which AI Gateway was vulnerable to insecure template expansion of user supplied data via crafted Duo Agent Platform Flow definitions. This vulnerability could be used to cause Denial of Service or gain code execution on the Gateway. This has been fixed in versions 18.6.2, 18.7.1, and 18.8.1 of the GitLab AI Gateway.
How to fix
- gitlab ai-gateway18.6.2, 18.7.1, 18.8.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| gitlab ai-gateway | 18.1.6 ≤ v < 18.6.2, 18.7.0 ≤ v < 18.7.1, 18.8.0 ≤ v < 18.8.1 | 18.6.2, 18.7.1, 18.8.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.