CVE-2026-18733

High

Description

A prompt injection vulnerability in the shell tool in Amazon Strands Agents Tools before 0.8.0 might allow remote actors to execute arbitrary operating system commands on the agent's host via a crafted prompt that sets the non_interactive parameter to true, bypassing the human consent gate. To remediate this issue, users should upgrade to version 0.8.0.

SeverityHigh
CVSS8.8
Exploit probability—
ProductAws Strands-agents-tools
PublishedAug 3, 2026
First seenAug 3, 2026
Weakness typeCWE-1427CWE-1427

How to fix

Affected products

ProductAffected versionsFixed in
AWS strands-agents-toolsv < 0.8.00.8.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.