CVE-2026-19359

Medium

Description

A security vulnerability has been detected in nxp-auto-goldvip gvip up to 1.4.0. Affected by this issue is the function SitewiseCustomFunction of the component Lambda Function Handler. Such manipulation leads to improper access controls. The attack can be launched remotely. Upgrading to version 1.15.0 can resolve this issue. Upgrading the affected component is advised. The project explains: "The reported IAM permission configuration is a known historical issue that was already addressed in 2024, beginning with GoldVIP version 1.13.0. The permissions were updated in subsequent releases, including version 1.15.0. In addition, we also sent a request to either update or deprecate the older release in the AWS SAR application repository."

SeverityMedium
CVSS4.7
Exploit probability—
ProductNxp-auto-goldvip Gvip
PublishedAug 9, 2026
First seenAug 9, 2026

How to fix

Affected products

ProductAffected versionsFixed in
nxp-auto-goldvip gvip1.0, 1.1, 1.2, 1.3, 1.4.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.