CVE-2026-19589
High
Description
Packer up to 1.15.4 is vulnerable to an issue in the third-party plugin installer that may allow unintended file system modification and could lead to code execution. A user who installs a plugin from a malicious or compromised source may be affected. This vulnerability (CVE-2026-19589) is fixed in Packer 1.16.0.
SeverityHigh
CVSS7.1
Exploit probability—
ProductPacker
PublishedAug 17, 2026
First seenAug 17, 2026
Weakness typeCWE-22Path traversal
How to fix
Update
- HashiCorp Packer1.16.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| HashiCorp Packer | 1.7.0 ≤ v < 1.16.0 | 1.16.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.