CVE-2026-2100
Description
A flaw was found in p11-kit. A remote attacker could exploit this vulnerability by calling the C_DeriveKey function on a remote token with specific IBM kyber or IBM btc derive mechanism parameters set to NULL. This could lead to the RPC-client attempting to return an uninitialized value, potentially resulting in a NULL dereference or undefined behavior. This issue may cause an application level denial of service or other unpredictable system states.
How to fix
- p11-kit_project p11-kit0.26.2 or later
- redhat cert-manager_operator1.17.2, 1.18.2, 1.20.1 or later
- redhat cost_management_metrics_operator4.4.1 or later
- access.redhat.com/errata/RHSA-2026:18143
- access.redhat.com/errata/RHSA-2026:18599
- access.redhat.com/errata/RHSA-2026:21275
- access.redhat.com/errata/RHSA-2026:22634
- access.redhat.com/errata/RHSA-2026:27998
- access.redhat.com/errata/RHSA-2026:58981
- access.redhat.com/errata/RHSA-2026:7065
- access.redhat.com/errata/RHSA-2026:72502
- access.redhat.com/errata/RHSA-2026:82304
- access.redhat.com/errata/RHSA-2026:82322
- access.redhat.com/errata/RHSA-2026:82347
- access.redhat.com/errata/RHSA-2026:82354
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| p11-kit_project p11-kit | No range specified, v < 0.26.2 | 0.26.2 |
| redhat hardened_images | No range specified | — |
| redhat enterprise_linux | 9.0, 10.0, 6.0, 7.0, 8.0 | — |
| redhat cert-manager_operator | 1.17.0 ≤ v < 1.17.2, 1.18.0 ≤ v < 1.18.2, 1.20.0 ≤ v < 1.20.1 | 1.17.2, 1.18.2, 1.20.1 |
| redhat cost_management_metrics_operator | 4.0.0 ≤ v < 4.4.1 | 4.4.1 |
| redhat insights-proxy | 1.5.0 | — |
| redhat update_infrastructure | 5.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.