CVE-2026-22249
High
Description
Docmost is an open-source collaborative wiki and documentation software. From 0.21.0 to before 0.24.0, Docmost is vulnerable to Arbitrary File Write via Zip Import Feature (ZipSlip). In apps/server/src/integrations/import/utils/file.utils.ts, there are no validation on filename. This vulnerability is fixed in 0.24.0.
SeverityHigh
CVSS7.1
Exploit probability—
ProductDocmost
PublishedJan 15, 2026
First seenJan 15, 2026
Weakness typeCWE-22Path traversal
How to fix
Update
- docmost docmost0.24.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| docmost docmost | 0.21.0 ≤ v < 0.24.0 | 0.24.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.