CVE-2026-22250

Low

Description

wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, the SSL verification would be skipped for some crafted URLs. This vulnerability is fixed in 1.17.0.

SeverityLow
CVSS2.5
Exploit probability—
ProductWeblate Wlc
PublishedJan 12, 2026
First seenJan 12, 2026
Weakness typeCWE-295CWE-295

How to fix

Update
  • weblate wlc1.17.0 or later
  • wlc1.17.0 or later

Affected products

ProductAffected versionsFixed in
weblate wlcv < 1.17.01.17.0
wlcPyPIv < 1.17.01.17.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.