CVE-2026-22265

High

Description

Roxy-WI is a web interface for managing Haproxy, Nginx, Apache and Keepalived servers. Prior to 8.2.8.2, command injection vulnerability exists in the log viewing functionality that allows authenticated users to execute arbitrary system commands. The vulnerability is in app/modules/roxywi/logs.py line 87, where the grep parameter is used twice - once sanitized and once raw. This vulnerability is fixed in 8.2.8.2.

SeverityHigh
CVSS7.5
Exploit probability—
ProductRoxy-wi
PublishedJan 15, 2026
First seenJan 15, 2026

How to fix

Update
  • roxy-wi roxy-wi8.2.8.2 or later

Affected products

ProductAffected versionsFixed in
roxy-wi roxy-wiv < 8.2.8.28.2.8.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.