CVE-2026-22597

Low

Description

Ghost is a Node.js content management system. In versions 5.38.0 through 5.130.5 and 6.0.0 through 6.10.3, a vulnerability in Ghost’s media inliner mechanism allows staff users in possession of a valid authentication token for the Ghost Admin API to exfiltrate data from internal systems via SSRF. This issue has been patched in versions 5.130.6 and 6.11.0.

SeverityLow
CVSS2.7
Exploit probability—
ProductGhost
PublishedJan 10, 2026
First seenJan 10, 2026

How to fix

Update
  • ghost ghost5.130.6, 6.11.0 or later
  • ghost6.11.0, 5.130.6 or later

Affected products

ProductAffected versionsFixed in
ghost ghost5.38.0 ≤ v < 5.130.6, 6.0.0 ≤ v < 6.11.05.130.6, 6.11.0
ghostnpm6.0.0 ≤ v < 6.11.0, 5.105.0 ≤ v < 5.130.66.11.0, 5.130.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.