CVE-2026-22704
High
Description
HAX CMS helps manage microsite universe with PHP or NodeJs backends. In versions 11.0.6 to before 25.0.0, HAX CMS is vulnerable to stored XSS, which could lead to account takeover. This issue has been patched in version 25.0.0.
SeverityHigh
CVSS8.0
Exploit probability—
ProductPsu Haxcms-nodejs
PublishedJan 10, 2026
First seenJan 10, 2026
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- @haxtheweb/haxcms-nodejs25.0.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| psu haxcms-nodejs | 11.0.6 | — |
| @haxtheweb/haxcms-nodejsnpm | 11.0.6 ≤ v < 25.0.0 | 25.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.