CVE-2026-22773

Medium

Description

vLLM is an inference and serving engine for large language models (LLMs). In versions from 0.6.4 to before 0.12.0, users can crash the vLLM engine serving multimodal models that use the Idefics3 vision model implementation by sending a specially crafted 1x1 pixel image. This causes a tensor dimension mismatch that results in an unhandled runtime error, leading to complete server termination. This issue has been patched in version 0.12.0.

SeverityMedium
CVSS6.5
Exploit probability—
ProductVllm
PublishedJan 10, 2026
First seenJan 10, 2026

How to fix

Update
  • vllm vllm0.12.0 or later
  • vllm0.12.0 or later

Affected products

ProductAffected versionsFixed in
vllm vllm0.6.4 ≤ v < 0.12.00.12.0
vllmPyPI0.6.4 ≤ v < 0.12.00.12.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-22773 · Vllm · Dark Radar