CVE-2026-22778

Critical

Description

vLLM is an inference and serving engine for large language models (LLMs). From 0.8.3 to before 0.14.1, when an invalid image is sent to vLLM's multimodal endpoint, PIL throws an error. vLLM returns this error to the client, leaking a heap address. With this leak, we reduce ASLR from 4 billion guesses to ~8 guesses. This vulnerability can be chained a heap overflow with JPEG2000 decoder in OpenCV/FFmpeg to achieve remote code execution. This vulnerability is fixed in 0.14.1.

SeverityCritical
CVSS9.8
Exploit probability—
ProductVllm
PublishedFeb 2, 2026
First seenFeb 2, 2026
Weakness typeCWE-532CWE-532

How to fix

Affected products

ProductAffected versionsFixed in
vllm vllm0.8.3 ≤ v < 0.14.10.14.1
vllmPyPI0.8.3 ≤ v < 0.14.10.14.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.