CVE-2026-23480

High

Description

Blinko is an AI-powered card note-taking project. Prior to version 1.8.4, there is a privilege escalation vulnerability. The upsertUser endpoint has 3 issues: it is missing superAdminAuthMiddleware, any logged-in user can call it; the originalPassword is an optional parameter and if not provided password verification is skipped; there is no check for input.id === ctx.id (ownership verification). This could result in any authenticated user modifying other users' passwords, direct escalation to superadmin, and complete account takeover. This issue has been patched in version 1.8.4.

SeverityHigh
CVSS8.8
Exploit probability—
ProductBlinko
PublishedMar 23, 2026
First seenMar 23, 2026
Weakness typeCWE-288CWE-288

How to fix

Update
  • blinko blinko1.8.4 or later

Affected products

ProductAffected versionsFixed in
blinko blinkov < 1.8.41.8.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.