CVE-2026-23490

High

Description

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.2, a Denial-of-Service issue has been found that leads to memory exhaustion from malformed RELATIVE-OID with excessive continuation octets. This vulnerability is fixed in 0.6.2.

SeverityHigh
CVSS7.5
Exploit probability—
ProductPyasn1
PublishedJan 16, 2026
First seenJan 16, 2026

How to fix

Affected products

ProductAffected versionsFixed in
pyasn1 pyasn1v < 0.6.20.6.2
debian debian_linux11.0—
pyasn1PyPI0.6.1 ≤ v < 0.6.20.6.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.