CVE-2026-23498
High
Description
Shopware is an open commerce platform. From 6.7.0.0 to before 6.7.6.1, a regression of CVE-2023-2017 leads to an array and array crafted PHP Closure not checked being against allow list for the map(...) override. This vulnerability is fixed in 6.7.6.1.
SeverityHigh
CVSS7.2
Exploit probability—
Product
Shopware
PublishedJan 14, 2026
First seenJan 14, 2026
Weakness typeCWE-94Code injection
How to fix
Update
- shopware shopware6.7.6.1 or later
- shopware/shopware6.7.6.1 or later
- shopware/core6.7.6.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| shopware shopware | 6.7.0.0 ≤ v < 6.7.6.1 | 6.7.6.1 |
| shopware/shopwarePackagist | 6.7.0.0 ≤ v < 6.7.6.1 | 6.7.6.1 |
| shopware/corePackagist | 6.7.0.0 ≤ v < 6.7.6.1 | 6.7.6.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.