CVE-2026-23535

High

Description

wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.

SeverityHigh
CVSS8.0
Exploit probability—
ProductWeblate Wlc
PublishedJan 16, 2026
First seenJan 16, 2026

How to fix

Update
  • weblate wlc1.17.2 or later
  • wlc1.17.2 or later

Affected products

ProductAffected versionsFixed in
weblate wlcv < 1.17.21.17.2
wlcPyPIv < 1.17.21.17.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.