CVE-2026-2360

High

Description

PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a custom operator in the public schema and place malicious code in that operator. This operator will later be executed with superuser privileges when the extension is created. The risk is higher with PostgreSQL 14 or with instances upgraded from PostgreSQL 14 or a prior version. With PostgreSQL 15 and later, the creation permission on the public schema is revoked by default and this exploit can only be achieved if a superuser adds a new schema in her/his own search_path and grants the CREATE privilege on that schema to untrusted users, both actions being clearly discouraged by the PostgreSQL documentation. The problem is resolved in PostgreSQL Anonymizer 3.0.1 and further versions

SeverityHigh
CVSS8.0
Exploit probability—
ProductPostgreSQL Anonymizer
PublishedFeb 11, 2026
First seenFeb 11, 2026
Weakness typeCWE-427CWE-427

How to fix

Update
  • DALIBO PostgreSQL Anonymizer3.0.1 or later

Affected products

ProductAffected versionsFixed in
DALIBO PostgreSQL Anonymizer1 ≤ v < 3.0.13.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.