CVE-2026-2361

High

Description

PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a temporary view based on a function containing malicious code. When the anon.get_tablesample_ratio function is then called, the malicious code is executed with superuser privileges. This privilege elevation can be exploited by users having the CREATE privilege in PostgreSQL 15 and later. The risk is higher with PostgreSQL 14 or with instances upgraded from PostgreSQL 14 or a prior version because the creation permission on the public schema is granted by default. The problem is resolved in PostgreSQL Anonymizer 3.0.1 and further versions

SeverityHigh
CVSS8.0
Exploit probability—
ProductPostgreSQL Anonymizer
PublishedFeb 11, 2026
First seenFeb 11, 2026
Weakness typeCWE-427CWE-427

How to fix

Update
  • DALIBO PostgreSQL Anonymizer3.0.1 or later

Affected products

ProductAffected versionsFixed in
DALIBO PostgreSQL Anonymizer1 ≤ v < 3.0.13.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-2361 · PostgreSQL Anonymizer · Dark Radar