CVE-2026-23643
Medium
Description
CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.
SeverityMedium
CVSS5.4
Exploit probability—
Product
Cakephp
PublishedJan 16, 2026
First seenJan 16, 2026
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- cakephp cakephp5.2.12 or later
- cakephp/cakephp5.2.12, 5.3.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| cakephp cakephp | 5.2.10 ≤ v < 5.2.12, 5.3.0 | 5.2.12 |
| cakephp/cakephpPackagist | 5.2.10 ≤ v < 5.2.12, 5.3.0 ≤ v < 5.3.1 | 5.2.12, 5.3.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.