CVE-2026-23794
Medium
Description
Reflected XSS in Apache Syncope's Enduser Login page. An attacker that tricks a legitimate user into clicking a malicious link and logging in to Syncope Enduser could steal that user's credentials. This issue affects Apache Syncope: from 3.0 through 3.0.15, from 4.0 through 4.0.3. Users are recommended to upgrade to version 3.0.16 / 4.0.4, which fix this issue.
SeverityMedium
CVSS6.8
Exploit probability—
Product
Apache Syncope
PublishedFeb 3, 2026
First seenFeb 3, 2026
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- apache syncope3.0.16, 4.0.4 or later
- org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui3.0.16, 4.0.4 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache syncope | 3.0.0 ≤ v < 3.0.16, 4.0.0 ≤ v < 4.0.4 | 3.0.16, 4.0.4 |
| org.apache.syncope.client.idrepo:syncope-client-idrepo-common-uiMaven | 3.0.0 ≤ v < 3.0.16, 4.0.0 ≤ v < 4.0.4 | 3.0.16, 4.0.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.