CVE-2026-23891

High

Description

Decidim is a participatory democracy framework. In versions below 0.30.5 and 0.31.0.rc1 through 0.31.0, a stored code execution vulnerability in the user name field allows a low-privileged attacker to execute arbitrary code in the context of any user who passively visits a comment page, resulting in high confidentiality and integrity impact across security boundaries. This issue has been fixed in versions 0.30.5 and 0.31.1.

SeverityHigh
CVSS8.7
Exploit probability—
ProductDecidim
PublishedApr 13, 2026
First seenApr 13, 2026

How to fix

Update
  • decidim decidim0.30.5, 0.31.1 or later

Affected products

ProductAffected versionsFixed in
decidim decidimv < 0.30.5, 0.31.0 ≤ v < 0.31.10.30.5, 0.31.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.