CVE-2026-23981

Medium

Description

An Improper Authorization vulnerability exists in Apache Superset allowing an authenticated user with permissions to update charts to modify dashboards they do not own. When updating a chart's properties via the REST API, a user can provide a list of dashboard IDs (dashboards) to associate the chart with. The validation logic in the UpdateChartCommand failed to verify that the user had write permissions for the target dashboards specified in the request body. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

SeverityMedium
CVSS4.3
Exploit probability—
ProductApache Superset
PublishedJul 30, 2026
First seenJul 30, 2026
Weakness typeCWE-285CWE-285

How to fix

Update
  • apache superset6.0.0 or later

Affected products

ProductAffected versionsFixed in
apache supersetv < 6.0.06.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.