CVE-2026-23982

Medium

Description

An Improper Authorization vulnerability exists in Apache Superset that allows a low-privileged user to bypass data access controls. When creating a dataset, Superset enforces permission checks to prevent users from querying unauthorized data. However, an authenticated attacker with permissions to write datasets and read charts can bypass these checks by overwriting the SQL query of an existing dataset. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Superset
PublishedFeb 24, 2026
First seenFeb 24, 2026

How to fix

Update
  • apache superset6.0.0 or later
  • apache-superset6.0.0 or later

Affected products

ProductAffected versionsFixed in
apache supersetv < 6.0.06.0.0
apache-supersetPyPIv < 6.0.06.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.