CVE-2026-23983

Medium

Description

A Sensitive Data Exposure vulnerability exists in Apache Superset allowing authenticated users to retrieve sensitive user information. The Tag endpoint (disabled by default) allows users to retrieve a list of objects associated with a specific tag. When these associated objects include Users, the API response improperly serializes and returns sensitive fields, including password hashes (pbkdf2), email addresses, and login statistics. This vulnerability allows authenticated users with low privileges (e.g., Gamma role) to view sensitive authentication data This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue or make sure TAGGING_SYSTEM is False (Apache Superset current default)

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Superset
PublishedFeb 24, 2026
First seenFeb 24, 2026

How to fix

Update
  • apache superset6.0.0 or later
  • apache-superset6.0.0 or later

Affected products

ProductAffected versionsFixed in
apache supersetv < 6.0.06.0.0
apache-supersetPyPIv < 6.0.06.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.