CVE-2026-24098
Medium
Description
Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this issue
SeverityMedium
CVSS6.5
Exploit probability—
Product
Apache Airflow
PublishedFeb 9, 2026
First seenFeb 9, 2026
Weakness typeCWE-200Sensitive information exposure
How to fix
Update
- apache airflow3.1.7 or later
- apache-airflow3.1.7 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache airflow | 3.0.0 ≤ v < 3.1.7 | 3.1.7 |
| apache-airflowPyPI | v < 3.1.7, 3.0.0 ≤ v < 3.1.7 | 3.1.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.