CVE-2026-24128
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Versions 7.0-milestone-2 through 16.10.11, 17.0.0-rc-1 through 17.4.4, and 17.5.0-rc-1 through 17.7.0 contain a reflected Cross-site Scripting (XSS) vulnerability, which allows an attacker to craft a malicious URL and execute arbitrary actions with the same privileges as the victim. If the victim has administrative or programming rights, those rights can be exploited to gain full access to the XWiki installation. This issue has been patched in versions 17.8.0-rc-1, 17.4.5 and 16.10.12. To workaround, the patch can be applied manually, only a single line in templates/logging_macros.vm needs to be changed, no restart is required.
How to fix
- xwiki xwiki16.10.12, 17.4.5, 17.8.0 or later
- org.xwiki.platform:xwiki-platform-web-templates16.10.12, 17.4.5, 17.8.0-rc-1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| xwiki xwiki | 7.0.1 ≤ v < 16.10.12, 17.0.1 ≤ v < 17.4.5, 17.6.0 ≤ v < 17.8.0, 7.0, 17.0.0 | 16.10.12, 17.4.5, 17.8.0 |
| xwiki xwiki-rendering | 17.5.0 | — |
| org.xwiki.platform:xwiki-platform-web-templatesMaven | 7.0-milestone-2 ≤ v < 16.10.12, 17.0.0-rc-1 ≤ v < 17.4.5, 17.5.0-rc-1 ≤ v < 17.8.0-rc-1 | 16.10.12, 17.4.5, 17.8.0-rc-1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.