CVE-2026-24135
Description
Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, a path traversal vulnerability exists in the updateWikiPage function of Gogs. The vulnerability allows an authenticated user with write access to a repository's wiki to delete arbitrary files on the server by manipulating the old_title parameter in the wiki editing form. This issue has been patched in versions 0.13.4 and 0.14.0+dev.
How to fix
- gogs gogs0.13.4 or later
- gogs.io/gogs0.13.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| gogs gogs | v < 0.13.4 | 0.13.4 |
| gogs.io/gogsGo | v < 0.13.4, No range specified | 0.13.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.