CVE-2026-24136
Description
Saleor is an e-commerce platform. Versions 3.2.0 through 3.20.109, 3.21.0-a.0 through 3.21.44 and 3.22.0-a.0 through 3.22.28 have a n Insecure Direct Object Reference (IDOR) vulnerability that allows unauthenticated actors to extract sensitive information in plain text. Orders created before Saleor 3.2.0 could have PIIs exfiltrated. The issue has been patched in Saleor versions: 3.22.29, 3.21.45, and 3.20.110. To workaround, temporarily block non-staff users from fetching order information (the order() GraphQL query) using a WAF.
How to fix
- saleor saleor3.20.110, 3.21.45, 3.22.29 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| saleor saleor | 3.2.0 ≤ v < 3.20.110, 3.21.0 ≤ v < 3.21.45, 3.22.0 ≤ v < 3.22.29 | 3.20.110, 3.21.45, 3.22.29 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.