CVE-2026-24421

Medium

Description

phpMyFAQ is an open source FAQ web application. Versions 4.0.16 and below have flawed authorization logic which exposes the /api/setup/backup endpoint to any authenticated user despite their permissions. SetupController.php uses userIsAuthenticated() but does not verify that the requester has configuration/admin permissions. Non-admin users can trigger a configuration backup and retrieve its path. The endpoint only checks authentication, not authorization, and returns a link to the generated ZIP. This issue is fixed in version 4.0.17.

SeverityMedium
CVSS6.5
Exploit probability78. percentile1.7%
ProductPhpmyfaq
PublishedJan 24, 2026
First seenJan 24, 2026

How to fix

Update
  • phpmyfaq phpmyfaq4.0.17 or later
  • phpmyfaq/phpmyfaq4.0.17 or later
  • thorsten/phpmyfaq4.0.17 or later

Affected products

ProductAffected versionsFixed in
phpmyfaq phpmyfaqv < 4.0.174.0.17
phpmyfaq/phpmyfaqPackagistv < 4.0.174.0.17
thorsten/phpmyfaqPackagistv < 4.0.174.0.17

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.