CVE-2026-24713
Critical
Description
Improper Input Validation vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7. Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
SeverityCritical
CVSS9.8
Exploit probability55. percentile0.7%
Product
Apache Iotdb
PublishedMar 9, 2026
First seenMar 9, 2026
Weakness typeCWE-20Improper input validation
How to fix
Update
- apache iotdb1.3.7, 2.0.7 or later
- org.apache.iotdb:iotdb-core1.3.7, 2.0.7 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache iotdb | 1.0.0 ≤ v < 1.3.7, 2.0.0 ≤ v < 2.0.7 | 1.3.7, 2.0.7 |
| org.apache.iotdb:iotdb-coreMaven | 1.0.0 ≤ v < 1.3.7, 2.0.0 ≤ v < 2.0.7 | 1.3.7, 2.0.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.