CVE-2026-24733
Description
Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.
How to fix
- apache tomcat9.0.113, 10.1.50, 11.0.15 or later
- org.apache.tomcat:tomcat-coyote11.0.15, 10.1.50, 9.0.113 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat | 9.0.1 ≤ v < 9.0.113, 10.1.1 ≤ v < 10.1.50, 11.0.1 ≤ v < 11.0.15, 9.0.0, 10.0.0, 11.0.0 | 9.0.113, 10.1.50, 11.0.15 |
| org.apache.tomcat:tomcat-coyoteMaven | 11.0.0-M1 ≤ v < 11.0.15, 10.1.0-M1 ≤ v < 10.1.50, v < 9.0.113 | 11.0.15, 10.1.50, 9.0.113 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.