CVE-2026-24734

High

Description

Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native:  from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114. The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected. Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue. Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Tomcat
PublishedFeb 17, 2026
First seenFeb 17, 2026

How to fix

Update
  • apache tomcat9.0.115, 10.1.52, 11.0.18 or later
  • apache tomcat_native1.3.5, 2.0.12 or later
  • org.apache.tomcat:tomcat-coyote11.0.18, 10.1.52, 9.0.115 or later
  • org.apache.tomcat.embed:tomcat-embed-core11.0.18, 10.1.52, 9.0.115 or later
  • org.apache.tomcat:tomcat-coyote-ffm11.0.18, 10.1.52, 9.0.115 or later

Affected products

ProductAffected versionsFixed in
apache tomcat9.0.83 ≤ v < 9.0.115, 10.1.1 ≤ v < 10.1.52, 11.0.1 ≤ v < 11.0.18, 10.1.0, 11.0.09.0.115, 10.1.52, 11.0.18
apache tomcat_native1.3.0 ≤ v < 1.3.5, 2.0.0 ≤ v < 2.0.121.3.5, 2.0.12
org.apache.tomcat:tomcat-coyoteMaven11.0.0-M1 ≤ v < 11.0.18, 10.1.0-M7 ≤ v < 10.1.52, 9.0.83 ≤ v < 9.0.11511.0.18, 10.1.52, 9.0.115
org.apache.tomcat.embed:tomcat-embed-coreMaven11.0.0-M1 ≤ v < 11.0.18, 10.1.0-M7 ≤ v < 10.1.52, 9.0.83 ≤ v < 9.0.11511.0.18, 10.1.52, 9.0.115
org.apache.tomcat:tomcat-coyote-ffmMaven11.0.0-M1 ≤ v < 11.0.18, 10.1.0-M7 ≤ v < 10.1.52, 9.0.83 ≤ v < 9.0.11511.0.18, 10.1.52, 9.0.115

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.