CVE-2026-24851

High

Description

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.8.5 to v1.11.2 ( openfga-0.2.22<= Helm chart <= openfga-0.2.51, v.1.8.5 <= docker <= v.1.11.2) are vulnerable to improper policy enforcement when certain Check calls are executed. The vulnerability requires a model that has a a relation directly assignable by a type bound public access and assignable by type bound non-public access, a tuple assigned for the relation that is a type bound public access, a tuple assigned for the same object with the same relation that is not type bound public access, and a tuple assigned for a different object that has an object ID lexicographically larger with the same user and relation which is not type bound public access. This vulnerability is fixed in v1.11.3.

SeverityHigh
CVSS8.8
Exploit probability—
ProductOpenfga Helm Charts
PublishedFeb 6, 2026
First seenFeb 6, 2026

How to fix

Update
  • openfga helm_charts0.2.51 or later
  • openfga openfga1.11.3 or later
  • github.com/openfga/openfga1.11.3 or later

Affected products

ProductAffected versionsFixed in
openfga helm_charts0.2.22 ≤ v < 0.2.510.2.51
openfga openfga1.8.5 ≤ v < 1.11.31.11.3
github.com/openfga/openfgaGo1.8.5 ≤ v < 1.11.31.11.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.