CVE-2026-24880

High

Description

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache Tomcat via invalid chunk extension. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M1 through 10.1.52, from 9.0.0.M1 through 9.0.115, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other, unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.20, 10.1.52 or 9.0.116, which fix the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Tomcat
PublishedApr 9, 2026
First seenApr 9, 2026
Weakness typeCWE-444CWE-444

How to fix

Update
  • apache tomcat9.0.116, 10.1.53, 11.0.20 or later
  • org.apache.tomcat:tomcat-coyote9.0.116, 10.1.52, 11.0.20 or later
  • org.apache.tomcat.embed:tomcat-embed-core9.0.116, 10.1.52, 11.0.20 or later

Affected products

ProductAffected versionsFixed in
apache tomcat9.0.0 ≤ v < 9.0.116, 10.1.0 ≤ v < 10.1.53, 11.0.0 ≤ v < 11.0.209.0.116, 10.1.53, 11.0.20
org.apache.tomcat:tomcat-coyoteMaven7.0.0 ≤ v < 9.0.116, 10.1.0-M1 ≤ v < 10.1.52, 11.0.0-M1 ≤ v < 11.0.209.0.116, 10.1.52, 11.0.20
org.apache.tomcat.embed:tomcat-embed-coreMaven7.0.0 ≤ v < 9.0.116, 10.1.0-M1 ≤ v < 10.1.52, 11.0.0-M1 ≤ v < 11.0.209.0.116, 10.1.52, 11.0.20

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.