CVE-2026-25054
Description
n8n is an open source workflow automation platform. Prior to versions 1.123.9 and 2.2.1, a Cross-Site Scripting (XSS) vulnerability existed in a markdown rendering component used in n8n's interface, including workflow sticky notes and other areas that support markdown content. An authenticated user with permission to create or modify workflows could abuse this to execute scripts with same-origin privileges when other users interact with a maliciously crafted workflow. This could lead to session hijacking and account takeover. This issue has been patched in versions 1.123.9 and 2.2.1.
How to fix
- n8n n8n1.123.9, 2.2.1 or later
- n8n2.2.1, 1.123.9 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| n8n n8n | v < 1.123.9, 2.0.0 ≤ v < 2.2.1 | 1.123.9, 2.2.1 |
| n8nnpm | 2.0.0 ≤ v < 2.2.1, v < 1.123.9 | 2.2.1, 1.123.9 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.