CVE-2026-25483
Description
Craft Commerce is an ecommerce platform for Craft CMS. In versions from 4.0.0-RC1 to 4.10.0 and from 5.0.0 to 5.5.1, a stored XSS vulnerability exists in Craft Commerce’s Order Status History Message. The message is rendered using the |md filter, which permits raw HTML, enabling malicious script execution. If a user has database backup utility permissions (which do not require an elevated session), an attacker can exfiltrate the entire database, including all user credentials, customer PII, order history, and 2FA recovery codes. This issue has been patched in versions 4.10.1 and 5.5.2.
How to fix
- craftcms craft_commerce4.10.1, 5.5.2 or later
- craftcms/commerce5.5.2, 4.10.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| craftcms craft_commerce | 4.0.1 ≤ v < 4.10.1, 5.0.0 ≤ v < 5.5.2, 4.0.0 | 4.10.1, 5.5.2 |
| craftcms/commercePackagist | 5.0.0 ≤ v < 5.5.2, 4.0.0-RC1 ≤ v < 4.10.1 | 5.5.2, 4.10.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.