CVE-2026-25547

Critical

Description

@isaacs/brace-expansion is a hybrid CJS/ESM TypeScript fork of brace-expansion. Prior to version 5.0.1, @isaacs/brace-expansion is vulnerable to a denial of service (DoS) issue caused by unbounded brace range expansion. When an attacker provides a pattern containing repeated numeric brace ranges, the library attempts to eagerly generate every possible combination synchronously. Because the expansion grows exponentially, even a small input can consume excessive CPU and memory and may crash the Node.js process. This issue has been patched in version 5.0.1.

SeverityCritical
CVSS9.2
Exploit probability—
Product@isaacs/brace-expansion
PublishedFeb 4, 2026
First seenFeb 4, 2026
Weakness typeCWE-1333CWE-1333

How to fix

Update
  • @isaacs/brace-expansion5.0.1 or later

Affected products

ProductAffected versionsFixed in
@isaacs/brace-expansionnpmv < 5.0.15.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.