CVE-2026-25747
Description
Deserialization of Untrusted Data vulnerability in Apache Camel LevelDB component. The Camel-LevelDB DefaultLevelDBSerializer class deserializes data read from the LevelDB aggregation repository using java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. An attacker who can write to the LevelDB database files used by a Camel application can inject a crafted serialized Java object that, when deserialized during normal aggregation repository operations, results in arbitrary code execution in the context of the application. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.5, from 4.15.0 before 4.18.0. Users are recommended to upgrade to version 4.18.0, which fixes the issue. For the 4.10.x LTS releases, users are recommended to upgrade to 4.10.9, while for 4.14.x LTS releases, users are recommended to upgrade to 4.14.5
How to fix
- apache camel4.10.9, 4.14.5, 4.18.0 or later
- org.apache.camel:camel-leveldb4.10.9, 4.14.5, 4.18.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache camel | 3.0.0 ≤ v < 4.10.9, 4.11.0 ≤ v < 4.14.5, 4.15.0 ≤ v < 4.18.0 | 4.10.9, 4.14.5, 4.18.0 |
| org.apache.camel:camel-leveldbMaven | 3.0.0 ≤ v < 4.10.9, 4.11.0 ≤ v < 4.14.5, 4.15.0 ≤ v < 4.18.0 | 4.10.9, 4.14.5, 4.18.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.