CVE-2026-25903
Description
Apache NiFi 1.1.0 through 2.7.2 are missing authorization when updating configuration properties on extension components that have specific Required Permissions based on the Restricted annotation. The Restricted annotation indicates additional privileges required to add the annotated component to the flow configuration, but framework authorization did not check restricted status when updating a component previously added. The missing authorization requires a more privileged user to add a restricted component to the flow configuration, but permits a less privileged user to make property configuration changes. Apache NiFi installations that do not implement different levels of authorization for Restricted components are not subject to this vulnerability because the framework enforces write permissions as the security boundary. Upgrading to Apache NiFi 2.8.0 is the recommended mitigation.
How to fix
- apache nifi2.8.0 or later
- org.apache.nifi:nifi-web-api2.8.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache nifi | 1.1.0 ≤ v < 2.8.0 | 2.8.0 |
| org.apache.nifi:nifi-web-apiMaven | 1.1.0 ≤ v < 2.8.0 | 2.8.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.