CVE-2026-25917

High

Description

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low. Users are recommended to upgrade to Apache Airflow 3.2.0, which fixes the issue.

SeverityHigh
CVSS7.2
Exploit probability—
ProductApache Airflow
PublishedApr 18, 2026
First seenApr 18, 2026

How to fix

Update
  • apache airflow3.2.0 or later
  • apache-airflow-core3.2.0 or later
  • apache-airflow3.2.0 or later

Affected products

ProductAffected versionsFixed in
apache airflowv < 3.2.03.2.0
apache-airflow-corePyPIv < 3.2.03.2.0
apache-airflowPyPIv < 3.2.03.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.