CVE-2026-25957
Medium
Description
Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.
SeverityMedium
CVSS6.5
Exploit probability—
ProductCube.js
PublishedFeb 9, 2026
First seenFeb 9, 2026
Weakness typeCWE-755CWE-755
How to fix
Update
- cube cube.js1.4.2, 1.5.13 or later
- @cubejs-backend/server-core1.4.2, 1.5.13 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| cube cube.js | 1.1.17 ≤ v < 1.4.2, 1.5.0 ≤ v < 1.5.13 | 1.4.2, 1.5.13 |
| @cubejs-backend/server-corenpm | 1.1.17 ≤ v < 1.4.2, 1.5.0 ≤ v < 1.5.13 | 1.4.2, 1.5.13 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.