CVE-2026-26022

High

Description

Gogs is an open source self-hosted Git service. Prior to version 0.14.2, a stored cross-site scripting (XSS) vulnerability exists in the comment and issue description functionality. The application's HTML sanitizer explicitly allows data: URI schemes, enabling authenticated users to inject arbitrary JavaScript execution via malicious links. This issue has been patched in version 0.14.2.

SeverityHigh
CVSS8.7
Exploit probability—
ProductGogs
PublishedMar 5, 2026
First seenMar 5, 2026

How to fix

Update
  • gogs gogs0.14.2 or later
  • gogs.io/gogs0.14.2 or later

Affected products

ProductAffected versionsFixed in
gogs gogsv < 0.14.20.14.2
gogs.io/gogsGov < 0.14.2, No range specified0.14.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.