CVE-2026-26974

Critical

Description

Slyde is a program that creates animated presentations from XML. In versions 0.0.4 and below, Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file can execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. This issue has been fixed in version 0.0.5. To workaround this issue, users can audit and restrict which packages are installed in node_modules.

SeverityCritical
CVSS9.8
Exploit probability—
ProductSlyde
PublishedFeb 20, 2026
First seenFeb 20, 2026
Weakness typeCWE-829CWE-829

How to fix

Update
  • slyde.js slyde0.0.5 or later
  • @tygo-van-den-hurk/slyde0.0.5 or later

Affected products

ProductAffected versionsFixed in
slyde.js slydev < 0.0.50.0.5
@tygo-van-den-hurk/slydenpmv < 0.0.50.0.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.