CVE-2026-26987
Medium
Description
LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Versions 25.12.0 and below are vulnerable to Reflected XSS attacks via email field. This issue has been fixed in version 26.2.0.
SeverityMedium
CVSS6.1
Exploit probability—
ProductLibrenms
PublishedFeb 20, 2026
First seenFeb 20, 2026
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- librenms librenms26.2.0 or later
- librenms/librenms26.2.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| librenms librenms | v < 26.2.0 | 26.2.0 |
| librenms/librenmsPackagist | v < 26.2.0 | 26.2.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.