CVE-2026-27314
High
Description
Privilege escalation in Apache Cassandra 5.0 on an mTLS environment using MutualTlsAuthenticator allows a user with only CREATE permission to associate their own certificate identity with an arbitrary role, including a superuser role, and authenticate as that role via ADD IDENTITY. Users are recommended to upgrade to version 5.0.7+, which fixes this issue.
SeverityHigh
CVSS8.8
Exploit probability—
Product
Apache Cassandra
PublishedApr 7, 2026
First seenApr 7, 2026
Weakness typeCWE-267CWE-267
How to fix
Update
- apache cassandra5.0.7 or later
- org.apache.cassandra:cassandra-all5.0.7 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache cassandra | 5.0.0 ≤ v < 5.0.7 | 5.0.7 |
| org.apache.cassandra:cassandra-allMaven | 5.0-alpha1 ≤ v < 5.0.7 | 5.0.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.